Excel : Filtre conditionnel

Publié le 03 mai 2012
par Sophie Marchand M.Sc., CPA, CGA, MVP

Excel : Filtre conditionnel

Cette semaine, une lectrice m’a demandé comment elle pouvait effectuer un filtre sur deux colonnes dans Excel avec le critère OU. J’ai donc décidé de consacrer mon billet d’aujourd’hui filtres conditionnels dans Excel.

 

Mettre en place un filtre conditionnel dans Excel

Il existe sans doute plusieurs façons d’arriver à ce résultat, mais je suggère ici une approche simple. L’idée est d’ajouter une colonne dans votre tableau de données, qui affichera 1 ou 0 selon que les conditions sont rencontrées ou non. Il suffira ensuite d’effectuer un filtre sur les 1 de cette colonne, c’est-à-dire sur les lignes qui rencontrent les conditions.

 

Par filtres conditionnels, notre lectrice souhaite plus précisément insérer une règle avec des conditions OU (OR en anglais), imbriquées dans une formule de SI (IF). Dans l’exemple ci-dessous, supposons que nous voulions faire un filtre sur les items qui sont soit des ananas ou soit rouges, nous pourrions utiliser la formule =SI(OU(B6=$B$3;C6=$C$3);1;0). Ce faisant, on obtiendrait des 1 pour tous les items qui répondent à l’une ou l’autre des conditions.

filtre conditionnel dans Excel

 

Ensuite, il suffirait de filtrer les données sur le critère “1” comme suit:

 

J’espère avoir bien répondu à votre question Dominique!

 

CFO-Masque_Formations-en-ligne_FBLa mission du CFO masqué est de développer les compétences techniques des analystes et des contrôleurs de gestion en informatique décisionnelle avec Excel et Power BI et favoriser l’atteinte de leur plein potentiel, en stimulant leur autonomie, leur curiosité, leur raisonnement logique, leur esprit critique et leur créativité.

5 réflexions sur “Excel : Filtre conditionnel”

  1. bonjour,
    astuce intéressante. Petite précision:
    si vous ne mettez pas le IF, cela fonctionne également avec un résultat VRAI ou FAUX qui peut aussi être filtré.

  2. et en multipliant la formule par 1, on retrouve les 0 ou 1 au lieu des VRAI ou FAUX, ce qui peut être pratique pour un décompte du nombre de VRAI par exemple

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

Scroll to Top