Trouver l'erreur : Formule avec seulement des champs nommés

Accueil – Le CFO masqué Forums Excel Trouver l'erreur : Formule avec seulement des champs nommés

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Articles
  • #8895
    260M164
    Participant

    Bonjour,

    Jorge, Paul, peut-être pourrez-vous encore m’aider…. mais tous, vous êtes les bienvenus. Je suis toujours à travailler sur mon fichier des commissions. Pendant que l’on chercher à résoudre ma problématique d’une rechercheH avec 3 critères, je continue d’avancer l’élaboration de mon fichier.

    Et voilà qu’une formule qui semblait bien fonctionner, ne marche pas pour des # de contrats précis. J’ai pensé au début que c’était parce qu’ils débutaient avec un 0, mais non, car j’en ai d’autres et ça fonctionne.

    Je vous joins à nouveau mon fichier. Le problème se situe dans l’onglet “Relevés” où j’ai automatisé l’inscription du Gr.Courtier et de son taux de commission selon ce qui a été établi dans la table “Contrat”. C’est la même formule partout et il n’y a aucune valeur absolue dans ma formule. Je cherche à comprendre le pourquoi de cette erreur #N/A.

    Désespérée !

    Attachments:
    You must be logged in to view attached files.
    #8897
    Jorge
    Participant

    Salut Marie-France

    Après 45 min, je n’ai pas trouvé le erreur non plus. Donc, j’ai décidé plutôt d’utiliser INDEX-MATCH (INDEX-EQUIV) au lieu de VLOOKUP (RECHERCHEV) et ça a marché. J’ai comparé le deux versions (originale et modifiée) et je me suis rendu compte que la version original avec VLOOKUP ne retournait pas le champ pour le courtier no 2. Ça aussi fonctionne avec la nouvelle version.

    Je vous laisse ici le fichier modifié. Examinez-le bien parce que je l’ai travaillé à 10:45 pm et j’étais très fatigué

    Jorge

    Attachments:
    You must be logged in to view attached files.
    #8934
    guillaume
    Participant

    Bonjour,

    j’ai tenté de corrigé les erreurs N/A , ci joint, le champ “valeur proche ” n’était pas renseigné dans les formules, je ne sais pas si c’était ça le problème ?

    Cordialement

    Attachments:
    You must be logged in to view attached files.
    #8937
    260M164
    Participant

    Bonsoir Guillaume,
    Bonsoir Jorge,

    Trouver l’erreur: Formules avec seulement des champs nommés :
    Pour faire suite à la 1ere proposition de Guillaume concernant le format des No Contrat, je l’ai fait et cela n’a rien changé.
    Par contre, j’ai mis à profit votre 2e proposition, à savoir l’inscription du paramètre de la valeur proche (mon erreur) et WOW ! YÉ ! ça fonctionne ….du moins, dans le fichier que je vous ai fournis (Tableau_CFO-Simplifié). Lorsque j’insère ce paramètre dans mon vrai fichier, ça ne fonctionne plus 🙁

    Il faut dire que j’ai une condition préalable ajouté dans ma formule dont je ne vous avais pas montré pensant simplifier le tout et pensant aussi qu’une simple condition additionnelle à la formule ne changerait rien… erreur ! 🙁

    Cette condition vérifie si le champ No Contrat est vide (parfois c’est un boni, donc ce champs est vide). Si oui, automatiquement, “ABCD” doit s’inscrire pour la colonne “Gr.Courtier #1” de même que 100% dans la colonne suivante.
    Évidemment, cette condition fait aussi partie des colonnes suivantes, mais si la valeur est vrai, on doit renvoyer “” (vide) et 0% (car il ne reste plus rien pour les autres.. lol )
    Lorsque j’ajoute le paramètre manquant (valeur proche) dans la formule, c’est la formule elle-même qui s’inscrit dans ma cellule ??? =SI([@[No Contrat]]=””;”GFMD”;RECHERCHEV([@[No Contrat]];TablContrat[#Tout];EQUIV(TablContrat[[#En-têtes];[Gr.Courtier ‘#1]];TablContrat[#En-têtes];);0))

    Pourtant, j’ai ajouté ma condition Si dans le tableau que j’avais fourni (Tableau_CFO-Simplifié) avec le correctif de Guillaume et ça fonctionne.

    Jorge, il est vrai que votre proposition d’utiliser INDEX/EQUIV fonctionne aussi !! Merci, ça me donne une autre porte de sortie. Mais je me retrouve avec le même problème dans mon vrai fichier, dès je veux insérer ma condition “Si” … c’est la formule elle-même qui apparaît. Par contre, dans votre fichier, si j’ajoute la condition “si”, ça fonctionne.

    Il n’y en a pas un de vous deux qui demeure en Estrie par hasard ??

    Je vais essayer de regarder cela à nouveau à tête plus reposée .. car après la journée de travail, c’est moins évident.

    RechercheV avec 3 critères :
    Ah oui ! Guillaume …. C’est super ton idée de concatener pour mon problème de recherchev avec 3 critères … on “s’en fout” un peu d’avoir une colonne de plus … je n’aurai qu’à la cacher… l’important, c’est que ça marche !! Il va me rester à essayer cette idée dans mon vrai tableau. Je me crois les doigts

    Vous avez tous été super avec mes problématiques … je suis débutante dans ces formules avancées, mais avec ce genre de cas … et votre support .. je devrais apprendre assez vite. Encore merci pour tout le temps consacré.

    Je vous tiens au courant de mes progrès… il faut que je réussisse, mon client commence à s’impatienter :((

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.