Formule imbriquée trop longue dans validation de données

Accueil – Le CFO masqué Forums Excel Formule imbriquée trop longue dans validation de données

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #25946
    agamon
    Participant

    Bonjour à tous,

    Vous trouverez en PJ le fichier excel que j’utilise.
    Donc dans le classeur ‘Division_Dia’ j’ai l’inventaire de mes références classées par gamme de produits (ADALT, ALTO, ..). Dans le classeur ‘Liste_des_gammes’, j’ai l’ensemble des gammes. Mon but est de faciliter la recherche des infos concernant une réf donnée. J’utilise pour cela le classeur ‘Recherche_rapide_DIA’.

    Dans ce classeur je souhaite : pour la recherche par gamme :
    -dans la cellule B1 : liste déroulante avec les lettres alphabétiques de A à Z
    -dans la cellule B2 : liste déroulante avec le nom de toutes les gammes commençant par la lettre sélectionnée en B1
    -dans la cellule B4 : liste déroulante qui donne toutes les réfs de la gamme sélectionnée en B2
    -dans les cellules C4 à M4 : afficher les infos correspondant à la référence sélectionnée en B4

    pour la recherche par référence :
    -dans la cellule B16 : une formule qui permet d’indiquer le nom de la gamme de la référence qu’on aurai écris dans B18

    Voila, En espérant avoir été claire pour pouvoir m’aider au mieux. Dans le fichier excel vous verrez ce que j’ai fait, ca fonctionne relativement bien mais mes formules en SI dans validation de données sont bien trop longues. C’est gênant si je souhaite ajouter des gammes.

    Merci d’avance pour votre aide, dsl pour le roman :)))

    Attachments:
    You must be logged in to view attached files.
    #26002
    Julien
    Participant

    Bonjour,

    Pour simplifier les formules avec les SI, je propose l’usage de la fonction RechercheH et RechercheV.

    Dans la Colonne O, où on cherche les gamme commençant par une lettre variable, on peut faire une recherche horizontale :
    Formule en O3 : =RECHERCHEH($O$2;Liste_des_gammes!$A$2:$W$10;2;FAUX)

    Pour ce qui est de B13, tu peux faire une recherche verticale
    Formule en B16 : =RECHERCHEV(B18;B26:C31;2;FAUX)
    où B26:C31 stockera tes correspondances.

    Ca te permet de simplifier ta formule avec les SI, et d’ajouter des gammes (dans ce cas, n’oublie pas que tu devras changer la matrice des recherches).
    Il est toujours intéressant d’utiliser les Tableaux : https://www.lecfomasque.com/excel-mettre-sous-forme-de-tableau/

    En espérant avoir répondu à une partie de la problématique

    Attachments:
    You must be logged in to view attached files.
    #26252
    Sophie Marchand
    Participant

    Bonjour,

    Vous devriez plutôt utiliser une fonction INDEX.

    Les articles suivants pourraient vous éclairer:

    Fonction Excel: Index/Equiv (Index/Match)

    Excel: Effectuer un Index/Match (Index/Equiv) sur plusieurs plages de données

    Au plaisir,

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.