Excel recherche V + SI Cond ou SI Multiple

Accueil – Le CFO masqué Forums Excel Excel recherche V + SI Cond ou SI Multiple

Mots-clés : , ,

  • Ce sujet contient 1 réponse, 2 participants et a été mis à jour pour la dernière fois par Xavier Allart, le il y a 6 mois et 1 semaine.
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Articles
  • #134330
    Marc-André Vézina
    Participant

    Bonjour,

    J’ai un travail à remettre pour hier mais je n’arrive pas à faire une formule qui au départ me semble assez simple.

    J’aimerais que dans mon classeur, le premier onglet “07_DATA_FR_ADM_DÉPT” rapporte l’information des autres onglet à sa suite selon le département, le No. et le mois/an.

    Merci à tous pour votre aide,

    Attachments:
    You must be logged in to view attached files.
    #134333
    Xavier Allart
    Participant

    Bonjour

    Attention dans l’onglet 07_DATA_FR_ADM_DÉPT, dans la colonne G, les mois sont des dates “01/03/2024″avec un format nombre “mmm-aa’, alors que dans les autres tableaux dans les entêtes il s’agit de texte “mars-24”

    Attention utiliser les références absolues pour que la formule se recopie correctement.

    Je n’ai pas trouvé de solution avec somme.si.ens, mais en voici 3 autres

    Voici une proposition avec 2 formules rechercheX imbriquées pour réaliser la recherche verticale du No et horizontale du mois
    =RECHERCHEX([@[No.]];’00_GÉNÉRAL’!$D$4:$D$40;RECHERCHEX([@Mois];’00_GÉNÉRAL’!$F$3:$Q$3;’00_GÉNÉRAL’!$F$4:$Q$40);0)

    Voici une proposition avec la fonction sommeprod
    =SOMMEPROD((’00_GÉNÉRAL’!$D$4:$D$40=[@[No.]])*(’00_GÉNÉRAL’!$F$3:$Q$3=[@Mois])*’00_GÉNÉRAL’!$F$4:$Q$40)

    L’onglet Requêtes correspond à une solution en PowerQuery

    Cordialement

    Attachments:
    You must be logged in to view attached files.
2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.