Impossible de charger les données de cet élément visuel

Accueil – Le CFO masqué Forums Power BI Impossible de charger les données de cet élément visuel

  • Ce sujet contient 6 réponses, 2 participants et a été mis à jour pour la dernière fois par Sophie Marchand, le il y a 2 années et 12 mois.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Articles
  • #48738
    pfortin
    Participant

    Bonjour,

    J’ai créé un rapport avec Power BI Desktop et l’ai ensuite publié sur Power BI Service. Tous les visuels fonctionnent adéquatement sur le Desktop mais plusieurs d’entre eux ne fonctionnent pas lorsque j’essaie de les consulter en ligne sur le Service. “Impossible de charger les données de cet élément visuel”. Cependant, ce ne sont pas tous les visuels qui ne fonctionnent pas…

    Pouvez vous m’aider à comprendre ce que je dois faire ? Le message d’erreur m’indique seulement de réessayer plus tard mais j’essaie depuis ce matin et ça ne fonctionne toujours pas.

    Merci beaucoup.

    Attachments:
    You must be logged in to view attached files.
    #48743
    Sophie Marchand
    Participant

    Bonjour,

    À quel genre de source de données s’alimente ce visuel?

    Est-ce en mode importation ou connexion directe?

    Est-ce qu’il y a une année en cours de sélectionnée dans le rapport sur le service?

    Sophie

    #48744
    Sophie Marchand
    Participant

    Bonjour,

    À quel genre de source de données s’alimente ce visuel?

    Est-ce en mode importation ou connexion directe?

    Est-ce qu’il y a une année en cours de sélectionnée dans le rapport sur le service?

    Sophie

    #48747
    pfortin
    Participant

    La source de données à laquelle s’alimente les visuels qui ne fonctionnent pas sont des tables excel. Cependant, j’ai d’autres visuels qui s’alimentent à la même source de donnée (mêmes tables) et ces derniers fonctionnent.

    Je ne suis pas certaine de comprendre votre question sur le mode importation vs connexion directe, mais les données de mon logiciel client sont importées dans un excel et les tables du excel sont mis à jour à tous les matins. Par la suite, Power BI se connecte aux données importées dans Excel.

    Dans le rapport sur le service, effectivement il y avait une année sélectionnée, mais j’ai fait le test et même si je désélectionne l’année pour ne plus qu’il y ait de filtres, les visuels ne fonctionnent toujours pas sur le service.

    Malgré tout, j’ai encore fait des tests ce matin et les visuels sont fonctionnels dans le .pbix sur PowerBI desktop.

    **J’ai aussi à plusieurs reprises republié le .pbix sur le service en écrasant le rapport déjà publié, et ça ne change rien.

    Merci pour votre aide.

    #48756
    Sophie Marchand
    Participant

    Bonjour,

    Je crois malheureusement que sans avoir accès au .pbix et aux sources de données, il ne sera pas possible de vous venir en aide…

    Je suis désolée.

    Sophie

    #48758
    pfortin
    Participant

    Bonjour, je comprend que sans le .pbix et les sources de données vous ne pouvez pas m’aider. Mais avant de tout vous envoyer, j’ai passé du temps à comprendre la corrélation entre les différents visuels qui ne fonctionnaient pas, et je crois avoir trouvé le problème.

    Je me suis rendu compte que tous les visuels non fonctionnels dans le service utilisent une mesure avec cette formule : VentesCumulatives = calculate([Ventes];datesytd(Dates[Date];”30 Novembre”)). (Puisque notre fin d’année fiscale est au 30 novembre, j’utilise cette formule)

    Dès que je l’ai changé et que j’ai écrit “30 November” (anglais) au lieu de “30 Novembre” (français), les visuels n’étaient plus fonctionnels dans le .pbix mais ils sont devenus fonctionnels sur le service.

    J’ai donc changé le paramètre de langue du service (qui était à automatique), et je l’ai mis français. Malgré tout, les visuels avec la formule “30 Novembre” (français) ne fonctionnent toujours pas sur le service..

    Mon problème est maintenant que tout dépendant de ma formule, soit les visuels dans Power BI Desktop ne fonctionnent pas, soit ce sont les visuels dans Power BI Service qui ne fonctionnent pas.

    Je ne sais pas si vous avez une idée de ce que je pourrais faire pour que ça fonctionne maintenant qu’on a mis le doigt sur le problème ?

    Merci

    #48759
    Sophie Marchand
    Participant

    Bonjour,

    Vous devez écrire “11-30” et ne pas utiliser le mot Novembre ou November.

    Vous pouvez vous référer à l’article suivant: https://www.lecfomasque.com/power-bi-annee-fiscale-vs-annee-calendrier/.

    Au plaisir,

    Sophie

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.