Fonction SI ET imbriquées dans EXCEL vs IF AND dans PWBI

Accueil – Le CFO masqué Forums Power BI Fonction SI ET imbriquées dans EXCEL vs IF AND dans PWBI

Mots-clés : 

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #42539
    gregory.martinez341
    Participant

    Bonjour dans excel il est possbile dans une fonction IF d’imbriqué une fonction ET, avec dans la fonction ET la possibilité de mettre plusieurs valeurs logiques. Or Dans Power BI la fonction AND n’accepte que deux valeur logique… Comment pourrait on mettre en pratique ce type de fonction imbriqué dans PWBI :
    Soit en A2 le CA 2017, soit Dans B2 le CA 2016
    =SI(ET(A2=>0;B2<=0;A2>B2);”New”;SI(ET(A2=>0;B2=>0;A2>B2);”Increase” ….
    l’idée et de savoir comment faire des test logique avec plus de deux arguements dans le AND de PWBI.
    Bien à vous.

    #42546
    Sophie Marchand
    Participant

    Bonjour,

    Power BI utilise le langage DAX, qui lui accepte les fonctions d’Excel IF, AND et OR. Par contre, Power BI ne travaille pas avec des cellules. Il travaille avec des tables et des colonnes de données.

    En revanche, si vous utilisez Power Query, vous avez accès à l’ajout de colonnes conditionnelles qui appliqueront des tests logiques à vos données. Mais encore là, on travaille avec des tables et des colonnes de données.

    Je ne suis pas certaine de bien comprendre ce que vous tentez de faire au juste et comment sont disposées vos données… Il serait préférable d’insérer votre fichier pour qu’on puisse comprendre ce que vous cherchez à faire.

    En attendant, vous pouvez aussi jeter un coup d’œil à cet article sur les paramètres de scénarios dans Power BI http://www.lecfomasque.com/power-bi-utiliser-les-parametres-de-scenarios/.

    Merci.

    Sophie

    #42584
    gregory.martinez341
    Participant

    Bonjour, en fait en cherchant je me suis dis qu’on pouvait imbriquer des fonction And dans des fonctions And, j’arrive a cette formule pour comparer et analyser le CA ( par produit et par Vendeurs), ne créant une mesure comme ceci :
    M_DIAG_2016_2017 = if(and([M_CA_2016]<=0;[M_CA_2017]>0);”NEW”;if(and([M_CA_2016]>0;[M_CA_2017]<=0);”LOST”;if(and(and([M_CA_2016]>0;[M_CA_2017]>0);([M_CA_2016]>[M_CA_2017]));”DEG”;if(and(and([M_CA_2016]>0;[M_CA_2017]>0);([M_CA_2016]<[M_CA_2017]));”INC”;”STB”)))).
    Cala permet d’analyser rapidement les CA, et de mettre en place un plan d’action ( l’idéal, avoir un diag sur les deux dernière années).
    Mais merci pour la fonction scénario 🙂 je connaissais pas.

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.