Utiliser sommeprod sur une occurence seulement

Accueil – Le CFO masqué Forums Excel Utiliser sommeprod sur une occurence seulement

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #42590
    monarc
    Participant

    Bonjour,
    J’ai un classeur qui contient des dates, des noms d’employés, des noms de clients, des heures travaillées chez les clients. J’ai utilisé la fonction sommeprod avec les conditions pour additionner les heures travaillées chez un client par un employé par jour.
    Il faut que le calcul se fasse sur la première occurrence qui répond aux conditions de la fonction sommeprod pour une journée mais pas pour les autres occurrences de la même journée. Il y a souvent plusieurs lignes dans la même journée qui répondent aux critères; je veux avoir une seule fois pour la même journée le total des heures.
    Je sais qu’un tableau croisé dynamique ferait le travail, mais pour différentes raisons, je ne peux pas faire de tableau croisé avec cette liste de données.
    Je joins un fichier exemple de ce que je cherche.
    Merci!

    Attachments:
    You must be logged in to view attached files.
    #42592
    Sophie Marchand
    Participant

    Bonjour,

    J’ai ajouté une colonne pour vérifier si la combinaison de critères survenait pour la première fois ou non. Ensuite, j’ai ajouté une colonne conditionnelle sur ce critère, ce qui vous donne le résultat recherché.

    Au plaisir.

    Sophie

    Attachments:
    You must be logged in to view attached files.
    #42600
    monarc
    Participant

    Merci Sophie,

    J’ai adapté ta formule proposée sur deux colonnes pour qu’elle soit dans une cellule :
    =SI(NB.SI.ENS($A$2:A2;A2;$B$2:B2;B2;$C$2:C2;C2)>1;0;SOMMEPROD($D$2:$D$27;($A$2:$A$27=A2)*($B$2:$B$27=B2)*($C$2:$C$27=C2))) et ça fonctionne super! Je vais maintenant pouvoir adapter ceci dans mon “vrai classeur”!

    Merci, je suis vraiment très contente, de plus, une réponse rapide! Je vais pouvoir m’endormir le cerveau à OFF ce soir!

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.