Trouver la prochaine cellule vide avec une formule

Accueil – Le CFO masqué Forums Excel Trouver la prochaine cellule vide avec une formule

Mots-clés : 

  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par Stéphane Lorin, le il y a 6 mois et 3 semaines.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #134286
    pascal.poulin
    Participant

    Bonjour,
    J’essaie depuis plusieurs heures avec ChatGPT de trouver la solution mais ça ne fonctionne pas, donc voici votre chance de battre l’IA 😉

    J’ai une liste de d’environ 500 dates dans la colonne A, et certaines lignes sont vides. Quelle formule dois-je mettre dans la colonne B pour trouver la date maximale de chaque “groupe de dates”? J’ai pensé que de trouver la prochaine ligne vide de la colonne A permettrait de découper les parties (du style trouves moi la date maximale parmi les prochaines cellules où tu vois une données, donc jusqu’à ce que tu trouves une cellule vide). Et il faudrait que je puisse coller cette formule de la colonne B pour toutes les lignes de la colonne B (donc de B2 à B500 disons). Idéalement sans VBA ou sans formule matricielle, pour que ça puisse se mettre à jour automatiquement si une date change.

    Par exemple, dans la colonne A, j’ai les dates et lignes suivantes (voir ci-dessous) (donc dans le premier groupe de 4 dates, la formule renverrait le 30/3/2024, dans le deuxième groupe, la formule de la colonne B renverrait 8/06/2026, etc.) J’ai pensé que la première partie de la formule vérifierait à partir de la ligne actuelle de la formule (exemple à B3 on chercherait dans A3:A$500) et que la ligne suivante (B4) on chercherait dans la plage à partir de la ligne actuelle vers le bas (donc A4:A$500), puis à B5 on cherche dans A5:A$500 et ainsi de suite. Merci de votre aide! 🙂

    1/03/2024
    1/03/2024
    30/03/2024
    27/02/2024
    (ligne vide)
    28/04/2026
    8/06/2026
    30/03/2026
    (ligne vide)
    7/02/2028
    (ligne vide)
    (ligne vide)
    12/07/2025
    11/04/2024
    (ligne vide)
    11/08/2025
    8/08/2025
    (ligne vide)
    4/09/2025
    17/09/2025
    (ligne vide)

    #134291
    pascal.poulin
    Participant

    Note: vous aurez compris que je pourrais mettre une formule “=Max(…) pour le petit groupe de date mais puisque je veux mettre ça pour la colonne entière qui a 500+ lignes, ce serait un exercice fastidieux et sujet aux erreurs…

    #134301
    Stéphane Lorin
    Participant

    Bonjour
    une proposition en 2 étapes par formules
    en B2 =SI(A2=””;B1;SI(A1=””;A2;MAX(A2;B1)))
    en C2 =SI(A2=””;B2;A2)
    puis tirer vers le bas

    Stéphane

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.