tableau à double entrée

Accueil – Le CFO masqué Forums Excel tableau à double entrée

  • Ce sujet contient 3 réponses, 2 participants et a été mis à jour pour la dernière fois par Stéphane Lorin, le il y a 3 semaines et 1 jour.
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Articles
  • #95756
    Bubble Pop
    Participant

    Bonjour
    Je sollicite votre aide pour m’aider par une formule sans matrice à trouver le bon résultat (D17) dans la cellule C17.
    L’idée est que YY et XX soient 2 variables dans la formule.

    Je reste à votre disposition si vous avez d’autres questions.
    Merci de votre aide.

    Attachments:
    You must be logged in to view attached files.
    #95760
    Stéphane Lorin
    Participant

    Bonjour

    Je vous propose de remplacer la fin de votre SOMME.SI par un INDEX de vos données avec l’argument “ligne” à 0 (pour récupérer toutes les lignes) et un EQUIV dans l’argument colonne pour déterminer le n° de la colonne XX ou YY…

    Cela donne la formule
    =SOMME.SI($B$3:$B$11;A17;INDEX($C$3:$D$11;0;EQUIV(B17;$C$2:$D$2;0)))

    Je préconise l’utilisation des tableaux (avec la colonne “Libellé” en B2)
    ce qui donne alors une formule du type
    =SOMME.SI(Tableau1[Libellé];A17;INDEX(Tableau1;0;EQUIV(B17;Tableau1[#En-têtes];0)))

    Stéphane

    #95762
    Bubble Pop
    Participant

    Bonjour,

    Merci pour votre réponse,
    cela fonctionnement parfaitement.

    #95763
    Stéphane Lorin
    Participant

    Très bien, merci de votre retour

    Au delà de la mise en forme tableau que je préconisais dans mon message précédent, il peut être intéressant d’utiliser Power Query pour dépivoter vos colonnes XX,YY… afin d’obtenir des données qui soient facile ensuite à analyser avec un Tableau Croisé Dynamique.
    La fonction SOMME.SI renvoie le résultat attendu, mais il est toujours utile me semble-t-il de rappeler quelques “bonnes pratiques” régulièrement expliquées par Sophie sur son site.
    Stéphane

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.