Somme SI Variable

Accueil – Le CFO masqué Forums Power BI Somme SI Variable

Mots-clés :  PowerBI Fonction DAX

  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par Matthieu, le il y a 7 mois et 1 semaine.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #89702
    Matthieu
    Participant

    Bonjour à tous,

    Le fichier Excel ci-joint contient 3 colonnes : Catégorie, % et % cumulé par Catégorie. Les colonnes catégories et % sont des données sources rentrées en dur. La 3eme colonne, % cumulé par Catégorie, contient la formule suivante (2eme ligne du xlsx): =SOMME.SI(A:A;A2;B:B)
    –> Cette dernière permet d’afficher pour chaque ligne le % cumulé de la catégorie concernée.

    Objectif : Je cherche à retranscrire cette formule dans le fichier pbix ci-joint (sous powerBI Desktop) en langage DAX, par l’intermédiaire d’une colonne calculée.
    La fonction DAX “CALCULATE” semble être la plus appropriée pour effectuer l’équivalent de la fonction “SOMME.SI” d’Excel, cependant je ne trouve que des exemples permettant de sommer pour une catégorie précise, exemple en langage DAX :
    % Cumulé par Catégorie = CALCULATE(
    sum(‘Somme Catégorie'[%]),
    filter(
    ‘Somme Catégorie’,
    ‘Somme Catégorie'[Catégorie] = “Catégorie 1″ ))

    Je cherche donc à pouvoir sommer les % des catégories tout en sachant que la catégorie sera variable dans ma fonction et non pas fixé comme dans l’exemple ci-dessus.

    % Cumulé par Catégorie = CALCULATE(
    sum(‘Somme Catégorie'[%]),
    filter(
    ‘Somme Catégorie’,
    ‘Somme Catégorie'[Catégorie] = ” ? ” ))

    En vous remerciant pour votre attention,

    Bonne journée

    Attachments:
    You must be logged in to view attached files.
    #89722
    Kim Leblanc
    Participant

    Bonjour,

    Il faudrait y aller avec ceci:

    % Cumulé par Catégorie =
    var cat = ‘Somme Catégorie'[Catégorie]
    RETURN
    CALCULATE(
    sum(‘Somme Catégorie'[%]),
    filter(
    all(‘Somme Catégorie’),
    ‘Somme Catégorie'[Catégorie] =cat ))

    On met en variable (var cat) la catégorie de la ligne actuelle.
    On utilise ensuite un all dans le filter pour ignorer les contextes de filtre sur la table Somme Catégorie puit on va chercher la somme en fonction de la variable cat.

    Kim

    • Cette réponse a été modifiée le il y a 7 mois et 1 semaine par Kim Leblanc.
    #89740
    Matthieu
    Participant

    Bonjour,

    Merci pour votre retour rapide, cette solution utilisant une variable fonctionne super bien !

    Bonne journée

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.