Somme comprise entre MIN et MAX

Accueil – Le CFO masqué Forums Excel Somme comprise entre MIN et MAX

5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Articles
  • #63423
    Abdelkhalek LABBIZE
    Participant

    Bonjour,
    À partir d’un tableau croisé dynamique, j’obtiens le nombre de décès par pays et par date (la table est celle fournie par https://raw.githubusercontent.com/CSSEGISandData/COVID-19/master/csse_covid_19_data/csse_covid_19_time_series/time_series_covid19_deaths_global.csv
    Je souhaite obtenir le nombre de décès AVANT et APRÈS la valeur maximale de chaque colonne de pays (en gros obtenir le nombre de décès au moment du pic de la pandémie pour chaque pays).
    Si quelqu’un a une solution…
    Ci-joint une capture d’écran du TCD

    Attachments:
    You must be logged in to view attached files.
    #63429
    Kim Leblanc
    Participant

    Bonjour,

    Ne sachant pas exactement comment vous importez les données, il est difficile de vous donner une réponse précise. Car nous ne savons pas comment sont structurés vos données.

    Néanmoins, de mon côté, je ne travaillerais pas avec un TCD, en fait, je ne suis pas sûre que l’on peut arriver à ce résultat à partir d’un TCD ou bien on se complique la vie.

    Si vous importez vos données via Power Query alors vous pouvez effectuer votre calcul directement dans Power Query.

    Si non, il serait possible de vous créer une liste de pays à partir de vos données et ensuite d’utiliser une combinaison de formules sommes.si.ens, max.si.ens, index/equiv. Qui ressemblerait à ceci:
    =SOMME.SI.ENS(Tableau1[Qty];Tableau1[Pays];$I4;Tableau1[Date];”<“&INDEX(Tableau1[Date];EQUIV(MAX.SI.ENS(Tableau1[Qty];Tableau1[Pays];$I4);Tableau1[Qty];0);0))

    Je vous joins un exemple.

    au plaisir,

    Kim

    Attachments:
    You must be logged in to view attached files.
    #63441
    Abdelkhalek LABBIZE
    Participant

    Bonjour Kim et merci pour votre réponse,
    J’aurais dû préciser que je traitais d’abord les données via Power Query et que le TCD n’est que l’un des tableaux de synthèses que j’obtiens de ma table.
    Serait-il possible de résoudre mon problème avec une mesure et, si oui, laquelle ?
    Merci d’avance pour votre aide.
    Bonne journée.

    #63465
    Kim Leblanc
    Participant

    Bonjour,

    Après quelques recherches, j’ai créé une mesure en dax que j’ai appliqué au modèle que je vous ai montré précédemment.

    La mesure dax pour le calcul avant la date avec le nombre maximal de cas est comme suit:

    QtyAvantPic:=VAR MaxQty =
    MAXX(Tableau1;Tableau1[Qty])
    VAR MaxDate=
    CALCULATE(Max(Tableau1[Date]);Tableau1;Tableau1[Qty]=MaxQty)
    RETURN
    Calculate(sum(Tableau1[Qty]);filter(Tableau1;Tableau1[Date]<MaxDate))

    Dans mon cas, s’il y a plusieurs dates avec le nombre maximal de cas alors il prendra la dernière date. Je vous joins mon fichier.

    Kim

    Attachments:
    You must be logged in to view attached files.
    #63468
    Abdelkhalek LABBIZE
    Participant

    Bonjour Kim,
    Cela semble marcher.
    Merci infiniment.
    Bonne journée !

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.