SI ET ou SI OU imbriqué….

Accueil – Le CFO masqué Forums Excel SI ET ou SI OU imbriqué….

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Articles
  • #58328
    Gwen
    Participant

    Bonjour je sèche sur ma formule ou je dois avoir plusieurs conditions :
    en fonction de la valeur d’une cellule je dois pouvoir renvoyer différentes valeurs, ma formule est la suivante et me renvoie l’erreur #VALEUR! :

    =SI(OU(AN2>0;AN2<=0,16666667;”Within 4Hrs”);SI(OU(AN2>0,16666667;AN2<=0,33333334;”Within 8Hrs”);SI(OU(AN2>0,33333334;AN2<=0,50000001;”Within 12Hrs”);SI(OU(AN2>0,50000001;AN2<=1,00000002;”Within 24Hrs”);SI(OU(AN2>1,00000002;AN2<=2,00000004;”Within 48Hrs”);SI(AN2>2,00000004;”More than48Hrs”))))))

    #58330
    Kim Leblanc
    Participant

    Bonjour,

    Il semble manquer une parenthèse pour fermer vos OU
    OU(AN2>0;AN2<=0,16666667)
    De plus dans cette partie de la formule, il aurait fallut utiliser un ET car vous voulez que la valeur soit plus grande que 0 et plus petite et égale à 0,1666667. En utilisant le OU, toutes les valeurs plus grande que 0 seront alors considéré comme vrai.

    Vous pourriez utiliser la fonction si.condition qui est plus simple à utiliser dans ce cas-ci. Les paramètres étant TestLogique1; valeur si vrai; TestLogique2; valeur si vrai. Dès que le TestLogique est considéré vrai, la formule s’arrête et donne la valeur si vrai.
    Il a alors moins d’imbrication de formule.

    Vous avez une explication de cette formule dans l’article suivant:

    Nouveautés Excel (janvier 2016): Des fonctions fort utiles (2 de 3)

    Si vous avez toujours de la difficulté avec la formule, svp nous soumettre un fichier avec un exemple de ce que vous souhaitez faire, et nous pourrons utiliser vos données pour vous aider avec la formule.

    Au plaisir,

    Kim

    #58361
    SL
    Participant

    Bonjour

    Et si vous avez 10, 20 ou plus de seuils, vous n’allez pas écrire une formule avec autant de SI
    La fonction EQUIV(..;..;1) est utile dans cette situation :

    Vous avez une table avec les seuils dans l’ordre croissant (le 1 du EQUIV permet de renvoyer le premier seuil inférieur à la valeur cherchée)

    Table_Seuil :

    Seuil Libellé
    0:00:00 <=4
    4:00:00 <=8
    8:00:00 <=12
    12:00:00 <=24
    24:00:00 <=48
    48:00:00 >48

    A noter que j’ajoute 10^-9 aux heures pour gérer le <= et non le < strict
    =”04:00:00″+10^-9

    Un INDEX combiné à un EQUIV(..;..;1) me donne le résultat souhaité
    =INDEX(Table_Seuil[Libellé];EQUIV([@Valeur];Table_Seuil[Seuil];1))

    Cordialement

    Attachments:
    You must be logged in to view attached files.
    #58364
    Gwen
    Participant

    AVEC MON FICHIER? PEUT ETRE PLUS SIMPLE
    MERCI POUR VOTRE AIDE…

    Attachments:
    You must be logged in to view attached files.
    #58378
    Gwen
    Participant

    Je n’arrive pas à créer la table et faire l’index avec la formule…

    #58382
    Gwen
    Participant

    Ca y est !!! C’est une réussite !! merci beaucoup pour votre aide, j’ai réussi à adapter a mon fichier et glissé la formule sur plus de 105 000 lignes !

    Merci à tous !

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.