Moyenne avec absence

Accueil – Le CFO masqué Forums Excel Moyenne avec absence

Mots-clés : 

  • Ce sujet contient 1 réponse, 2 participants et a été mis à jour pour la dernière fois par mel.forgues, le il y a 3 mois et 4 semaines.
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Articles
  • #137100
    DanyXLeHardi
    Participant

    Bonjour à tous,

    J’essaie de créer une formule pour additionner des résultats et réaliser une moyenne MAIS avec parfois des résultats manquants. Je m’explique via un tableau

    Maximum /10 /15 /25 Somme

    Albert 10 15 25 50

    Bernard 8 8 8 24

    Charles 9 A 25 34

    Comment faire pour compter la juste moyenne de Charles. En effet, celui-ci a été absent et son résultat est de 34/35. Comment adapter la formule pour exclure le 15 pour calculer son juste résultat sur 35 et les autres sur 50 pour ramener leur total sur 10 par exemple.

    MErci à vous

    #137110
    mel.forgues
    Participant

    Bonjour Dany,

    La réponse à votre question est en soit simple, par contre, si vous voulez plus de précision, il est important de joindre le fichier excel (sans données confidentielles) pour vous aider à résoudre la situation problématique.

    Entre temps, je vous ai gentiement monté très rapidement un fichier à partir des infos que vous m’avez fourni.

    Étapes:
    – 1 – PREPARER LES DONNEES
    En ligne 1, je place le pointage possible par test.
    En ligne 2, je place les résultats des étudiants pour chaque test.

    – 2 – DÉTERMINER LES FORMULES ÈA UTILISER
    Le calcul se fera à l’aide des formules SOMME(), SI() et ESTNUM(). Pour info: ESTNUM() renvoie VRAI si la cellule ciblé est un nombre et FAUX si ce n’est pas un nombre.

    – 3 – MONTER LES FORMULES, UNE A LA FOIS
    Pour faire la somme des résultats des élèves sans tenir compte des cases contant la lettre “A”:
    =SOMME(SI(ESTNUM($A2:$C2)=VRAI;($A2:$C2)))

    Pour faire la somme des pointages maximum possibles de chaque test selon les résultats de l’élève sans tenir compte de ceux dont l’élève n’a pas fait le test (les cases contant la lettre “A”):
    =SOMME(SI(ESTNUM($A2:$C2)=VRAI;($A$1:$C%1)))

    – 4 – TESTER TOUTES LES FORMULES

    -5- IMBRIQUER LES FORMULES POUR N’EN FAIRE QU’UNE SEULE
    … et ajouter la règle de 3 DANS la formule pour pondérer le résultat sur 10!

    Je ne suis pas certaine de comprendre la 2e partie. J’ai calculé les résultats selon les tests réalisés en appliquant une règle de 3 pour pondérer lee résultat sur 10, puis reconverti le résultat en poucentage.

    • Cette réponse a été modifiée le il y a 3 mois et 4 semaines par mel.forgues. Raison: ajouter le fichier
    Attachments:
    You must be logged in to view attached files.
2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.