Langage R

Mots-clés : 

  • Ce sujet contient 11 réponses, 4 participants et a été mis à jour pour la dernière fois par Cécile Dumetre, le il y a 6 mois.
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Articles
  • #127636
    Marie-Claude Dallaire
    Participant

    Bonjour,

    Je viens d’installer le langage R 4.3.3 (64bit) et RStudio pour Windows et je ne suis pas capable d’installer les packages anomalize et weathercan car, ils ne sont pas dans les choix lorsque je commence à taper. J’ai installé les packages anomaly et weathermetrics à la place. Est-ce l’équivalent ?

    Message pour anlomalize : le package ‘anomalize’ n’est pas disponible for this version of R

    Attachments:
    You must be logged in to view attached files.
    #127690
    CMichaud2
    Participant

    Bonjour,

    Ces 2 packages ne sont actuellement plus disponible sur le site https://cran.r-project.org/ ce qui explique le message d’erreur.

    Afin de contourner la situation, il est possible d’installer la version de développement du package anomalize à partir de github comme ceci :

    1. install.packages(“devtools”)

    2. devtools::install_github(“business-science/sweep”)

    3. devtools::install_github(“business-science/anomalize”)

    Concernant weathercan, celui-ci peut être installé à partir du site https://ropensci.r-universe.dev comme ceci :

    install.packages(“weathercan”,
    repos = c(“https://ropensci.r-universe.dev”,
    https://cloud.r-project.org”))

    Merci !

    #127725

    Bonjour Charles,

    Où dois-je taper ces informations ? Je suis allée sur les sites internet de Github et https://ropensci.r-universe.dev et je ne sais pas où allez ensuite. Est-ce possible d’avoir des print screens ? C’est un peu chinois pour moi ce genre de site.

    Merci !

    #127745
    CMichaud2
    Participant

    Bonjour,

    Voici plus précisément la procédure à suivre :

    1- Ouvrir RStudio

    2- Copier-coller chacune des 4 lignes de commande tel que dans la pièce jointe

    3- Positionner le curseur sur la première ligne de commande et cliquer sur “RUN” tel que dans la pièce jointe

    4- Faire la même chose pour les 3 autres lignes de commandes

    À noter que l’ordre des lignes de commande est important.

    Merci !

    Attachments:
    You must be logged in to view attached files.
    #127756

    Bonjour Charles,

    est-ce que tu peux regarder le fichier ci-joint car, il y a plusieurs messages d’erreur. Je ne vois pas la confirmation que le package anomalize a été installé avec succès. Weathercan a été installé avec succès.

    Merci !

    Marie-Claude

    #127757

    Bonjour Charles,

    voici mon fichier en format Word car, je ne peux joindre le fichier RSource sur ce forum.

    Attachments:
    You must be logged in to view attached files.
    #127808
    CMichaud2
    Participant

    Bonjour,

    Est-ce que vous voyez les packages Anomalize et Weathercan dans l’onglet “Packages” de RStudio tel qu’en pièce jointe ?

    Si c’est le cas, ils ont bien été installés.

    Sinon, vous devrez installer l’outil RTools via ce lien préalablement à l’installation des 2 packages :

    https://cran.r-project.org/bin/windows/Rtools/

    Merci !

    Attachments:
    You must be logged in to view attached files.
    #127825

    Bonjour Charles,

    Oui les packages Anomalize et Weathercan apparaissent dans l’onglet “Packages” de RStudio ! : )

    Voir mes questions concernant différents modules de la formation dans le fichier ci-joint.

    Merci !

    Marie-Claude

    Attachments:
    You must be logged in to view attached files.
    #127990
    Kim Leblanc
    Maître des clés

    Bonjour Marie-Claude,

    Voir mes réponses en rouge dans le fichier attaché.

    Bonne journée!

    Kim

    Attachments:
    You must be logged in to view attached files.
    #131929
    Cécile Dumetre
    Participant

    bonjour,

    pour ma part je n’arrive pas à installer le package “ggplot2” et tous ceux mentionnés dans la formation “aller plus loin avec le langage R”.

    pas réussi non plus à installer l’outil RTools via le lien cité precedemment

    merci

    Attachments:
    You must be logged in to view attached files.
    #131974
    CMichaud2
    Participant

    Bonjour,

    Cela semble dû à une configuration du réseau à partir duquel vous travaillez. Voici 2 pistes de solution :

    1. Réessayer à partir d’un autre réseau, soit à la maison ou bien en se connectant à un réseau cellulaire par exemple

    2. Dans RStudio, décocher l’option “Use secure download method for HTTP” tel que mentionné dans cet article –> https://community.rstudio.com/t/install-packages-unable-to-access-index-for-repository-try-disabling-secure-download-method-for-http/16578

    Merci!

    #131991
    Cécile Dumetre
    Participant

    Merci pour la réponse,
    j’avais déjà décoché “Use secure download method for HTTP”
    cela ne fonctionne pas, ni en changeant le réseau par un réseau cellulaire

    cdlt
    Cécile

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.