Index equiv entre 2 dates

Accueil – Le CFO masqué Forums Excel Index equiv entre 2 dates

  • Ce sujet contient 5 réponses, 2 participants et a été mis à jour pour la dernière fois par Xavier Allart, le il y a 2 mois et 3 semaines.
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Articles
  • #135253
    Yohan
    Participant

    Bonjour,

    Je travaille sur un fichier de rotation avec une information d’absence en cas de congé.

    Cependant mon index equiv ne fonctionne pas car je sélectionne la date de fin cependant je ne sais pas comme indiqué que cela doit se situé entre la date de début et de fin.

    En pièce jointe l’exemple de ce fichier. Si quelqu’un a une solution à m’indiquer.

    Merci d’avance pour votre aide!

    #135281
    Xavier Allart
    Participant

    Bonjour

    Je pense qu’il manque le fichier en piece jointe.

    Cordialement

    #135300
    Yohan
    Participant

    Bonjour,

    le fichier ne c’était en effet pas envoyé

    Cordialement

    Attachments:
    You must be logged in to view attached files.
    #135304
    Xavier Allart
    Participant

    Bonjour

    Une solution consite à créer depuis la table des absences une table de liste de dates automatique

    Il faudra bien penser à actualiser les données à chaque changement dans la table des absences

    Cordialement

    #135305
    Yohan
    Participant

    Bonjour et merci pour cette réponse cependant je ne saisi pas une chose:
    Le nécessaire est fait sur Powerquery cependant j aurais en effet une liste de jour de congé en dissociant les jours néanmoins je ne sais pas comment intégrer cela sur la formule pour indiquer dans l index équiv sur Excel que cela doit venir chercher à la fois la date et le matricule pour remonter l information « A » pour « absent »

    #135320
    Xavier Allart
    Participant

    Bonjour

    voici une solution, avec la fonction RECHERCHEX
    Ajouter une colonne avec la valeur “JF” dans la table des jours fériés
    Ajouter 2 colonnes dans la liste des absences :
    id = Matricule & Date
    “abs”

    Voici la formule à copier/coller (ne pas l’incrementer à cause des références structurées)
    =RECHERCHEX(C$2;Fériés!$B$6:$B$17;Fériés!$C$6:$C$17;SI(C$3>=6;”WE”;RECHERCHEX($B24&”-“&TEXTE(C$2;”AAAAMMJJ”);ListeDates[iD];ListeDates[Abs];””;0));0)

    Il s’agit de 3 fonctions imbriquées les unes dans les autres
    =RECHERCHEX(C$2;Fériés!$B$6:$B$17;Fériés!$C$6:$C$17;”fonction imbriquée”;0)
    SI(C$3>=6;”WE”;”fonction imbriquée”)
    RECHERCHEX($B24&”-“&TEXTE(C$2;”AAAAMMJJ”);ListeDates[iD];ListeDates[Abs];””;0)
    dans cette derniere on peut remplacer “” par C43

    Cordialement

    Attachments:
    You must be logged in to view attached files.
6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.