Contact: 514-605-7112 / info@lecfomasque.com

Formules SI(ET( imbriquées

Ce sujet a 8 réponses, 2 participants et a été mis à jour par  jla71, il y a 1 semaine et 5 jours.

9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #53172

    jla71
    Participant

    Bonjour Madame,

    J’ai construit un fichier excel avec plusieurs onglets pour la gestion de mise en conformité d’un parc machines suite à des observations issues de rapports de vérifications.

    Les formules fonctionnaient, jusqu’à ce qu’il me soit demandé un critère supplémentaire de classement par année de 2018 à 20222 que je dois ajouter aux autres critères et calculs…

    voici la formule qui fonctionne pour les cellules sur fond vert identifiés « C d D » pour chacun des acteurs et années, des colonnes AJ à HO. « C d D » signifie « Action Clôturée dans les Délais » :

    =SI(ET(ANNEE($S8)=$AJ$6;$R8=$AJ$5;$T8<=$S8;$T8<> » »;$U8= »Terminée »);1; » »)

    Les autres colonnes sont respectivement :
    « C h D » Action Clôturée hors délais ; par rapport à la date prévue
    « NC d D » Action Non Clôturée mais dans les délais ; par rapport à la date prévue
    « NC h D » Action Non clôturée et hors délais ; par rapport à la date prévue
    Je souhaiterai que chacune des autres cellules de ces mêmes colonnes soient alimentées selon les critères attendus comme la formule ci-dessus mais selon les exigences des nouvelles données.

    Je vous joins le fichier en question que j’ai allégé pour l’occasion.

    Merci de votre retour et excellente journée.

    Bien cordialement.

    • Ce sujet a été modifié le il y a 1 semaine et 6 jours par  jla71.
    fichiers attachés:
    You must be logged in to view attached files.
    #53176

    jla71
    Participant
    • Cette réponse a été modifiée le il y a 1 semaine et 6 jours par  jla71.
    #53182

    Sophie Marchand
    Admin bbPress

    Bonjour,

    J’ai ouvert votre fichier et il y a des références circulaires. Svp, commencez par régler vos références circulaires et mettez une colonne avec les résultats attendus. Je pourrai donc vous proposer une formule avec les résultats attendus. Mais tant qu’il y aura des références circulaires dans votre fichier, je ne vais pas me pencher sur la question car ces références circulaires peuvent être la source de plusieurs autres problèmes.

    Merci.

    Sophie

    #53191

    jla71
    Participant

    Bonsoir,

    Tout d’abord, merci de votre retour et de votre réactivité.
    Je viens de voir votre message. Je ne suis plus au bureau, il est 20h15 en France.
    Je regarde pour les références circulaires demain (ce pourrait il que ce soit lié au fait que j’ai supprimé plusieurs feuilles pour alléger le fichier pour envoi ?). Puis j’écrirais mes souhaits de résultat dans les cellules que je vous communiquerai.

    Bonne journée.

    Bien cordialement.

    Jérôme

    #53211

    jla71
    Participant

    Bonjour Madame,

    Ci-joint le fichier avec les souhaits de résultats dans les cellules AJ8 à AQ8. Pour les cellules AR8 à HO8, qui sont identiques, à ceci près que l’année et l’acteur changent, je pourrai faire des copié/collé de formules.
    Les sommes des résultats de ces formules, en ligne 1015, viendront alimenter mon onglet « Bilan par acteurs ».
    Si ma logique n’est pas bonne, je suis ouvert à toutes vos propositions.
    merci de votre retour et bonne journée.

    Bien cordialement.

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par  jla71.
    fichiers attachés:
    You must be logged in to view attached files.
    #53216

    Sophie Marchand
    Admin bbPress

    Bonjour,

    J’ai rédigé ci-dessous la formule qu’il vous faudrait pour la première cellule.

    =SIERREUR(SI.CONDITIONS(ET((ANNEE(S8)=AJ6),(R8=AJ5),(T8<>«  »),(T8<>«  »),(T8<=S8),(U8="Terminée")),1),0) À vous de faire le reste. Mon conseil, vous devriez apprendre à modéliser selon les règles de modélisation financière. Ceci vous permettrait d'être beaucoup plus efficace. Ici, vous tentez de faire des formules dans un onglet de présentation. Vous devriez plutôt avoir un onglet qui fait les calculs et dans cet onglet, il vous faudrait respecter les bonnes pratiques de la modélisation financière, i.e. disposer de blocs de calculs suivant une logique. Ensuite seulement, vous pourriez créer votre tableau actuel, basé sur les calculs de votre feuille de calculs. Je vous recommande fortement nos formations Excel - Mise à niveau et Excel - Modélisation financière (niveau 1), même si vous ne faites pas de modèles financiers, à proprement parler. Merci. Sophie

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par  Sophie Marchand.
    #53220

    jla71
    Participant

    Sophie,

    Je comprends votre position, cependant, je crains malheureusement de ne pas avoir l’occasion de venir au Canada, sauf peut-être pour des vacances. Donc compliqué de suivre une formation. De plus j’utilise rarement des formules de ce genre dans le cadre de mon travail.

    Puis-je supprimer ($T8<> » ») qui est deux fois dans votre formule ?

    J’ai donc copié votre formule dans la première cellule en remplaçant les « , » par « ; » car excel n’accepté pas les virgules. Puis j’ai également supprimé les espaces entre les signes « différents de », pour la même raison. Ensuite j’ai réalisé les autres formules selon votre méthode pour les résultats des cellules « action clôturée, mais hors délais », « action non clôturée, mais dans les délais » et enfin « action non clôturée et hors délais ».

    =SIERREUR(SI.CONDITIONS(ET((ANNEE($S8)=$AJ$6);($R8=$AJ$5);($T8<> » »);($T8<> » »);($T8>$S8);($U8= »Terminée »));1);0)

    =SIERREUR(SI.CONDITIONS(ET((ANNEE($S8)=$AJ$6);($R8=$AJ$5);($T8= » »);($T8= » »);($S8>=$HR$7);($U8<> »Terminée »));1);0)

    =SIERREUR(SI.CONDITIONS(ET((ANNEE($S8)=$AJ$6);($R8=$AJ$5);($T8= » »);($T8= » »);($S8<$HR$7);($U8<> »Terminée »));1);0)

    Ça fonctionne à priori. super.

    Merci beaucoup pour votre aide sur le sujet et excellente journée.

    Bien cordialement,

    Jérôme.

    #53221

    Sophie Marchand
    Admin bbPress

    Bonjour,

    Nos formations sont offertes en elearning donc pas besoin de vous déplacer au Canada. Vous pouvez les suivre en ligne. Vous pouvez effectivement supprimer mon doublon. C’est une erreur de retranscription.

    Je vous ai parlé des formations car je ne réponds habituellement pas aux questions dont les fichiers ne sont pas structurés comme ils le devraient, surtout si à cause de ça, ça me donne du fil à retordre. Je ne veux pas encourager les gens à aller dans la mauvaise direction en leur donnant une formule qui marche, tout en sachat qu’ils vont se buter à toutes sortes de difficultés semblables s’ils ne corrigent pas d’abord et avant tout leur façon de concevoir leurs fichiers.

    Au plaisir,

    Sophie

    #53222

    jla71
    Participant

    Sophie,
    J’ai bien pris note de vos différents commentaires et je vais m’attacher à suivre vos conseils concernant tout d’abord et avant toutes choses la façon de concevoir mes fichiers et pour cela suivre vos formations en ligne. Je pense même que plusieurs collègues ou connaissances seront certainement intéressés aussi. J’en parlerai donc également.

    Merci encore et très bonne journée.

    Jérôme

9 sujets de 1 à 9 (sur un total de 9)

Vous devez être connecté pour répondre à ce sujet.