Formule variation

Accueil – Le CFO masqué Forums Excel Formule variation

5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Articles
  • #65791
    Remi10
    Participant

    Bonjour,

    Je dois faire une variation entre deux périodes, mais ma formule doit s’adapter en fonction du sens des chiffres.

    je n’arrive pas à trouver la solution.
    je vous ai joint un exemple.

    Je vous remercie par avance pour votre aide.
    Rémi

    Attachments:
    You must be logged in to view attached files.
    #65794
    questvba
    Participant

    Bonjour,
    En C2, tu peux essayer cette formule :
    =SI(OU(ET(A2>=0;B2>=0);ET(A2<=0;B2<=0));B2-A2;B2+A2)
    est-ce que cela colle pour tous tes cas (négatif et positif) ?

    • Cette réponse a été modifiée le il y a 5 mois et 1 semaine par questvba.
    #65796
    Remi10
    Participant

    merci pour ta réponse.

    Je m’embrouille un peu :

    Au cours de l’exercice 2020 (B2) j’ai un résultat de -90 alors que pour l’exercice 2019 (A2) le résultat était de 100.

    la différence entre les deux exercices est bien de -190?
    Si oui, je cherche d’une formule qui s’ajuste en fonction du sens des montants.

    merci d’avance

    Attachments:
    You must be logged in to view attached files.
    #65798
    questvba
    Participant

    Re-,
    Voici le fichier avec la formule adaptée :
    =SI(OU(ET(A2>=0;B2>=0);ET(A2<=0;B2<=0);ET(A2>=0;B2<0));B2-A2;ABS(A2-B2))

    Attachments:
    You must be logged in to view attached files.
    #65801
    Remi10
    Participant

    parfait, merci beaucoup

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.