Fonctions SI.CONDITIONS et SI.MULTIPLE

Accueil – Le CFO masqué Forums Excel Fonctions SI.CONDITIONS et SI.MULTIPLE

  • Ce sujet contient 6 réponses, 6 participants et a été mis à jour pour la dernière fois par Stéphane Lorin, le il y a 8 mois et 1 semaine.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Articles
  • #64807
    Pimpin
    Participant

    Bonjour,

    Je possède la version 2016 d’EXCEL et cette dernière ne reconnaît pas les fonctions SI.CONDITIONS et SI.MULTIPLE. EXCEL m’affiche le message d’erreur « #NOM? ».
    Que dois-je faire pour utiliser ces fonctions ?

    Merci pour votre aide.

    #64808
    Sophie Marchand
    Participant

    Bonjour. Vous devez avoir la version Excel O365 ou Excel 2019 pour pouvoir utiliser ces fonctions. Merci.

    #64809
    Pimpin
    Participant

    Je vous remercie pour l’information.

    #96333
    diaba.ba
    Participant

    Bonjour Mme
    J’ai un souci pour combiner les fonctions SI OU ET ensemble. Je dois calculer le nombre de bénéficiaires pour certaines communes pour différentes types de bénéficiaires (Personnes déplacées internes, Refugiés, Retournées et communautés hôtes)

    =SI(OU(C2=”CHETIMARI”;C2=”MAINE SOROA”;C2=”CHADAKORI”; C2=”GUIDAN ROUMDJI”; C2=”TILLIA”; C2=”ABALA”;C2=”AYEROU”; C2=”OUALLAM”)); SI(ET(J2=”PAM”));0,42*X2)).

    Il me semble que j’ai des soucis au niveau des parenthèses mais je vous laisse m’aider.

    C2 = Nom de Commune
    J2 = Nom d’Organisation
    X2 = Total des Bénéficiaires
    AA = Nombre de réfugiés parmi les bénéficiaires
    0.42 = Pourcentage
    Merci d’avance
    Dba

    Attachments:
    You must be logged in to view attached files.
    #97210
    si_a
    Participant

    Bonjour,

    Si passait par une formule imbriqué avec la fonction “equiv”, je pense que la formule sera mois relou. Pour cela, il faut juste que tu mettes dans un autre onglet les communes que tu veux cibler.

    Voilà ce que je te propose en colonne AN:
    =SIERREUR(SI(ET(EQUIV(C2;Communes!$A$2:$A$9;0);J2=”PAM”);0,42*X2;””);””)

    La formule”Equiv” va chercher à identifier si le nom de la commune en C2 est dans la liste de l’onglet “Communes”.

    Si J2=PAM alors le résultat est vrai

    Si les 2 égalités sont vraies alors il fera le calcul, sinon il ne fera rien.

    Pour éviter le #N/A, j’ai introduit la fonction “sierreur”. Ce qui signifie que si la formule est fausse alors Excel ne fera pas de calcul. Si la formule est vrai et que les égalités sont vraies alors Excel fera le calcul demander.

    Si tu veux utiliser ta formule en colonne AON, il y a des erreurs.

    Ta version : =SI(OU(C2=”CHETIMARI”;C2=”MAINE SOROA”;C2=”CHADAKORI”; C2=”GUIDAN ROUMDJI”; C2=”TILLIA”; C2=”ABALA”;C2=”AYEROU”; C2=”OUALLAM”)); SI(ET(J2=”PAM”));0,42*X2)).

    la version corrigé :=SI(ET(OU(C2=”CHETIMARI”;C2=”MAINE SOROA”;C2=”CHADAKORI”;C2=”GUIDAN ROUMDJI”; C2=”TILLIA”; C2=”ABALA”;C2=”AYEROU”; C2=”OUALLAM”);J2=”PAM”);0,42*X2;””)

    Voilà

    Attachments:
    You must be logged in to view attached files.
    #97214
    Brice LE BLANC
    Participant

    Bonjour,

    Vous n’imbriquez pas les fonctions dans le bon ordre :

    =SI(ET(OU(C127=”CHETIMARI”;C127=”MAINE SOROA”;C127=”CHADAKORI”; C127=”GUIDAN ROUMDJI”; C127=”TILLIA”; C127=”ABALA”;C127=”AYEROU”; C127=”OUALLAM”); J127=”PAM”);0,42*X127;””)

    Voir fichier corrigé 🙂

    Attachments:
    You must be logged in to view attached files.
    #97216
    Stéphane Lorin
    Participant

    Bonjour

    Dans votre cas il est préférable de mettre dans une plage la liste des noms que vous cherchez et d’y faire référence avec un EQUIV

    OU(C2=”CHETIMARI”;C2=”MAINE SOROA”;C2=”CHADAKORI”; C2=”GUIDAN ROUMDJI”; C2=”TILLIA”; C2=”ABALA”;C2=”AYEROU”; C2=”OUALLAM”)
    devient
    ESTNUM(EQUIV(C2;votre_plage_de_recherche;0))
    qui renverra VRAI si C2 est dans la liste et FAUX sinon

    Il devient alors facile d’ajouter ou de supprimer un élément à cette liste

    Sinon, l’utilisation des tableaux est une très bonne pratique Excel et à ce titre fortement conseillée.

    Stéphane

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.