Fonction SOMME.SI.ENS (avec critère différent d’une liste)

Accueil – Le CFO masqué Forums Excel Fonction SOMME.SI.ENS (avec critère différent d’une liste)

  • Ce sujet contient 1 réponse, 2 participants et a été mis à jour pour la dernière fois par Xavier Allart, le il y a 1 semaine et 5 jours.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #137476
    JBisson
    Participant

    En effectuant un sommaire qui se calcul automatiquement à partir de la base de données (Projet et Nature comptable) avec la formule SOMME.SI.ENS.

    La formule en jaune est inadéquate (=SOMME.SI.ENS($C$15:$C$22;$B$15:$B$22;A8;A15:A22;”<>A2:A5″)), elle doit faire la somme si le projet n’est pas dans la liste plus haut et s’il respecte la nature comptable de cette ligne.

    Merci pour votre aide.

    Colonne A | Colonne B | commentaire
    Ligne 1 : Sommaire
    Projet Total Formule
    A 30
    B 0
    C 3
    D 10 =SOMME.SI.ENS($C$15:$C$22;$A$15:$A$22;A6)
    Autres:
    Salaire 138 =SOMME.SI.ENS($C$15:$C$22;$B$15:$B$22;A8;A15:A22;”<>A2:A5″)Devrait donner 100$
    Service professionnel Devrait donner 50$
    Stock Devrait donner 105$
    Total 293

    Base de données
    Projet Nature comptable Coûts
    A Salaire 10 $
    A Salaire 20 $
    C Salaire 3 $
    D Salaire 5 $
    E Service professionnel 50 $
    vide Salaire 100 $
    D Stock 5 $
    vide Stock 100 $
    Total 293 $

    Attachments:
    You must be logged in to view attached files.
    #137613
    Xavier Allart
    Participant

    Bonjour

    Voici 1 piste
    Si le nom des projets est composé d’une seule lettre et les autres de plusieures on peut utiliser le jocker “?”
    =SOMME.SI.ENS($C$16:$C$23;$B$16:$B$23;A8;$A$16:$A$23;”<>?”)
    Voir le lien suivant, il existe aussi “*” comme joker
    https://support.microsoft.com/fr-fr/office/fonction-somme-si-ens-c9e748f5-7ea7-455d-9406-611cebce642b
    ou celui ci : https://excel-malin.com/tutoriels/excel-fonctions/somme-si-ens/

    Amicalement

    #137718
    Xavier Allart
    Participant

    Bonjour

    Voici 1 piste
    Si le nom des projets est composé d’une seule lettre et les autres de plusieures on peut utiliser le jocker “?”
    =SOMME.SI.ENS($C$16:$C$23;$B$16:$B$23;A8;$A$16:$A$23;”<>?”)

    Amicalement

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.