[Excel 2016] – Contenu d'une cellule en fonction d'une autre au format Date

Accueil – Le CFO masqué Forums Excel [Excel 2016] – Contenu d'une cellule en fonction d'une autre au format Date

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #64494
    Mwasikitoko
    Participant

    Bonjour,
    j’ai un fichier avec une colonne correspondant à une date d’expiration…
    EN fonction de la date du jour, le remplissage est rouge si expiré, orange si expiration dans moins de 3 moins et jaune si expiration dans moins de 6 mois et vert si en curs (donc au delà de 6 mois).
    Ce remplissage est obtenu par mise ne forme conditionnelle.
    Je souhaiterais avoir une colonne qui affiche le texte en toute lettre.
    Je m’explique
    Date reference AUJ 10 MAI 2020
    Si en A4, j’ai Date Expiration 07/04/2020, la colonne est en rouge et la colonne suivante devra afficher “Expiré” en rouge et gras
    Je joins un fichier avec le format spécifique
    et j’ai essayé la formule suivante :

    =SI(AUJOURDHUI()>$A4;”Expiré”;SI(ET($A4>AUJOURDHUI();$A4=AUJOURDHUI()>MOIS.DECALER($A4;-6));”Expire dans 6 mois”;SI(ET($A4>AUJOURDHUI();$A4=AUJOURDHUI()>MOIS.DECALER($A4;-3));”Expire dans 3 mois”;SI($A4>AUJOURDHUI();”En cours”;)))

    mais je n’obtiens pas le résultat.
    J’utilise la version Excel365: j’ai testé Si.conditions sans succès.
    Mais la saisie se fera sur Excel2013 ou Excel 2017.
    Merci pour toute aide
    Mwasikitoko

    #64503
    Sophie Marchand
    Participant

    Vous n’avez pas inséré de fichier.

    #64775
    questvba
    Participant
3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.