DATE JOUR et Texte

Accueil – Le CFO masqué Forums Excel DATE JOUR et Texte

  • Ce sujet contient 6 réponses, 2 participants et a été mis à jour pour la dernière fois par Patrice Euristique, le il y a 2 années et 10 mois.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Articles
  • #46849
    Patrice Euristique
    Participant

    Bonjour,
    Une question qui va vous paraître simple vu le niveau des questions aperçues sur ce site.

    =SI(TEXTE(JOUR;MOIS)=TEXTE(B1;”jj/mm”);”Anniversaire”;””)

    Cette formule ne fonctionne pas, bien sur, mais vous voyez ce que je veux obtenir. Inscrire dans une cellule B2 le texte “Anniversaire” si JOUR et MOIS de B1 sont dito JOUR et MOIS d’ “AUJOURDHUI()” ?
    Pourrez-vous me donner la solution svp ?

    #46850
    Sophie Marchand
    Participant

    Bonjour,

    En supposant qu’en B1, vous avez entré une date complète en format date, la formule recherchée serait =SI(ET(MOIS(B1)=MOIS(AUJOURDHUI());JOUR(B1)=JOUR(AUJOURDHUI()));”Anniversaire”;”-“).

    Merci,

    Sophie

    #46854
    Patrice Euristique
    Participant

    Ah merci mais cela ne fonctionne pas et peut être à cause du format de la date qui est jj/mm/aaaa

    #46855
    Sophie Marchand
    Participant

    Si votre cellule est en format date et non en format texte, ça va fonctionner. Sinon, merci d’uploader votre fichier ici qu’on puisse voir ce qui ne fonctionne pas.

    #46895
    Patrice Euristique
    Participant

    La solution a été trouvée. Ce sont vos guillemets qui ne sont pas compatibles avec mon excel ou autre car en retapant la formule et non en copiant/collant, cela fonctionne !!!
    Après je ne m’explique pas

    #46896
    Sophie Marchand
    Participant

    C’est possible que le site web affiche les guillemets autrement. C’est pourquoi il est beaucoup plus facile de vous aider lorsque vous fournissez un fichier Exemple, dans lequel on peut directement travailler. Merci!

    #46897
    Patrice Euristique
    Participant

    Explication certaine et merci à vous !

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.