couleur dans cellule

Accueil – Le CFO masqué Forums Excel couleur dans cellule

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Articles
  • #47422
    Didier
    Participant

    Bonjour, j’aimerais que lorsqu’un element est dans les cases jaunes à j-1
    La cellule du noms devient rouge. En VBA
    Un grand merci pour votre aide

    Attachments:
    You must be logged in to view attached files.
    #47548
    Laurent78
    Participant

    Bonjour,
    Afin de comprendre la problématique, pourriez-vous joindre le fichier excel avec (mis à la main) les cellules que vous souhaitez en rouge ?
    Cdlt
    Laurent

    #47556
    Didier
    Participant

    Bonjour voici l’exemple de ce j’aimerais obtenir, merci d’avance.
    Cordialement.
    Didier.

    Attachments:
    You must be logged in to view attached files.
    #47749
    Laurent78
    Participant

    Bonjour,
    Ci-joint une solution sans VBA (attention, fichier Excel au “nouveau” format, xlsx). Je ai utilisé uniquement la mise en forme conditionnelle, et en utilisant SOMME.SI.ENS.
    Dites nous si cela vous convient. Y avait-il un impératif à utiliser le VBA ?
    Cdlt,
    Laurent

    Attachments:
    You must be logged in to view attached files.
    #47751
    Laurent78
    Participant

    si jamais vous aviez besoin de conserver l’ancien format (.xls) vous pouvez aussi remplacer la formule de la mise en forme conditionnelle par :
    =SOMMEPROD((C4:I4<>””)*((C$3:I$3=$C$1)+(C$3:I$3=$C$1-1)))
    Cdlt
    Laurent

    #47754
    Didier
    Participant

    Bonjour, et merci de votre aide très rapide c’est parfait et non je n’avais pas d’impératif à utiliser VBA

    Très cordialement

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.