Conditions supplémentaires à la fonction SI

Accueil – Le CFO masqué Forums Excel Conditions supplémentaires à la fonction SI

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Articles
  • #42328
    Tchantal
    Participant

    Bonjour à tous,
    Mon premier message est une demande d’aide pour rédiger une formule plutôt complexe.

    J’ai un début de formule dans la colonne E mais, j’ai besoin de 3 choses supplémentaires que je ne sais pas comment intégrer dans la formule.
    Si le mot Deleted est détecté dans le texte dans la colonne D, le montant dois être en négatif. Si New ou Added est détecté, le montant reste en positif.
    Le montant dans ma colonne E doit aussi être multiplié par le nombre dans la colonne C.
    Il doit absolument y avoir des données inscrites dans les colonnes C, F et G pour voir un résultat dans la colonne E.

    Merci pour votre aide!
    Je vous ai joins mon fichier. forum.xls

    Attachments:
    You must be logged in to view attached files.
    #42334
    Sophie Marchand
    Participant

    Bonjour,

    Pour la multiplication par 1 ou -1, vous pourriez utiliser une fonction comme la suivante:

    =SI(ESTNUM(TROUVE(“Deleted”,D3)),-1,1)

    On cherche le mot Deleted dans l’expression et si on le trouve, on rapporte un chiffre, qui représente sa position dans la chaîne de caractères, sinon, on retourne une erreur.

    En imbriquant le tout dans une fonction ESTNUM, on se trouve à obtenir un VRAI pour les chiffres et un faux pour les erreurs.

    Ce faisant, chaque fois que le mot Deleted sera trouvé à l’intérieur de l’expression, on aura un VRAI, sinon un FAUX et lorsqu’on aura un VRAI, on affichera -1 alors qu’on affichera 1 pour un FAUX.

    Vous pourrez ensuite récupérer ce chiffre pour le multiplier par votre autre expression.

    Pour la balance, je crois que vous serez en mesure de terminer votre formule.

    Au plaisir,

    Sophie

    #42338
    Tchantal
    Participant

    Bonjour Sophie,

    Je penses que votre réponse est trop avancée pour mon niveau.

    J’ai testé =SI(ESTNUM(TROUVE(“Deleted”,D3)),-1,1), seul dans une cellule, et pour D8 où il y a le mot Deleted, le résultat est un 1.
    Si je recherche de l’aide sur ESTNUM, je ne trouve rien.

    J’ai vraiment besoin d’aide pour jumeler les besoins décrit dans la formule déjà en place.

    Merci

    #42339
    Sophie Marchand
    Participant

    Évidemment, à la ligne 8, vous devez entrer D8… j’ai fait le test de mon côté et ça fonctionne. Ça donne bien -1. Voici le fichier.

    Attachments:
    You must be logged in to view attached files.
4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.