Compter le nombre de lignes

Accueil – Le CFO masqué Forums Excel Compter le nombre de lignes

  • Ce sujet contient 6 réponses, 3 participants et a été mis à jour pour la dernière fois par Christophe, le il y a 1 année et 4 mois.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Articles
  • #122501
    Christophe
    Participant

    Bonjour,
    Je voudrais compter le nombre de lignes en fonction de deux colonnes. J’ai utilisé la fonction nb.si.ens mais je ne la maîtrise pas. Quelqu’un a t’il la solution ?

    Attachments:
    You must be logged in to view attached files.
    #122504
    Stéphane Lorin
    Participant

    Bonjour

    Par exemple en cellule A2 :

    =NB.SI.ENS(C$2:C2;C2) mais ça peut être lourd si vous avec des milliers de lignes, le $ est important pour compter toujours depuis la ligne 2.

    =SI(C2=C1;A1+1;1) puisque vos n° de commande semblent triés

    je vous encourage à utiliser les tableaux structurés, c’est une très bonne pratique dans Excel.

    Stéphane

    #122509
    Christophe
    Participant

    Bonjour Stéphane,
    Je vous remercie pour votre réponse qui fonctionne. Est-il possible d’ajouter le résultat dans la même formule pour obtenir le N° de commande et le N° de ligne de la commande ? Cela donnerait 1221030-1; 1221044-1, 1221044-2
    Merci d’avance,

    #122568
    Stéphane Lorin
    Participant

    Bonjour

    quelque chose comme
    =C2&”-“&NB.SI.ENS(C$2:C2;C2)

    Si vous avez une volumétrie importante de données, il est intéressant d’utiliser Power Query pour transformer vos données

    Stéphane

    #122614
    Christophe
    Participant

    Bonjour,
    Je vous remercie. Je n’ai pas besoin de passer par Power Query mais merci pour vos renseignements qui m’ont été utiles.

    #123150
    Sylvie Giroux
    Participant

    Je ne connais pas ton besoin de retrouver cette information directement dans ta base de données, mais si c’est pour connaître le nombre de répétition d’un numéro de code, tu pourrais obtenir l’information autrement via un tableau croisé dynamique. Je te joints le fichier démontrant les possibilités en lien avec ta demande.

    Attachments:
    You must be logged in to view attached files.
    #124524
    Christophe
    Participant

    Bonjour Sylvie,
    Je te remercie pour tes conseils mais je ne pouvais pas utiliser de TCD dans ce cas car les informations seront retraitées par une macro ensuite. Merci du conseil pour la mise en forme sous forme de tableau que je connaissais déjà. Merci en tous cas !
    Christophe

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.