Chaos dans les formats à l’ouverture fichier..

Accueil – Le CFO masqué Forums Excel Chaos dans les formats à l’ouverture fichier..

  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par divjal, le il y a 1 mois.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Articles
  • #82885
    divjal
    Participant

    Bonjour,

    Voilà une dizaine de jours que je suis en train d’essayer de résoudre un problème (peu courant) sur un fichier XLSM.
    Les faits , synthétises :
    2 feuilles distinctes :
    – N°1 avec 3 cellules fusionnées et caractères formatées + couleurs.
    – N°2 une autre contenant des données en colonnes formatées aussi , mais possédant dans un coin une attribution de couleur personnalisée…
    C’est apparemment cette couleur personnalisée qui crée le soucis décrit dans la cinématique ci-dessous :
    – Ouverture fichier => Ok sur les 2 pages
    – Modif d’une cellule (n’importe laquelle) dans la feuille de données N°2 => Ok
    – Vérif feuille 1 : Ok pas de changements.
    – Fermeture fichier => Ok
    – Réouverture fichier => Ok
    – Vérif feuille 2 => Pas de Pb pour la cellule modifiée.
    – Vérif feuille 1 => Les cellules fusionnées on perdu leurs formats. (plus de fusion, plus de formats caractères ni de couleur)

    En faisant des essais, et en avançant pas à pas, j’ai pu voir que dans un nouveau fichier crée, je pouvais recoller les formats de toutes les autres cellules sans faire réapparaître le problème, sauf celles qui avait bénéficié de couleur personnalisée.. Là le problème réapparaissait !

    J’ai pensé à un problème de “collisions” dans les styles, mais malgré beaucoup de recherches, ne suis pas parvenu a nettoyer cela…

    Ah, j’oubliais : le fichier est sain, contrôlé avec plusieurs Antivirus différents.
    Aussi : même problèmes notre PC portable…

    Avez-vous déjà rencontré cette situation ? (J’ai sur le web lu des gens qui avaient eu le même soucis et qui avaient résolu le problème en supprimant des formats personnalisés “exotiques”, qui étaient venus d’on ne sait où …
    J’en ai trouvé moi aussi, mais après suppression: pas d’amélioration !
    Je sèche !
    Merci par avance…

    #82907
    Sophie Marchand
    Participant

    Bonjour,

    Ce sera difficile de vous aider sans avoir accès à votre fichier. Comme il s’agit d’un fichier avec macros, le comportement peut être dû à une ligne de code spécifique.

    Sinon, vous pourriez toujours tenter d’utiliser l’option “Nettoyer l’excès de mise en forme des cellules” du menu “Inquire”, si vous utilisez une version Excel qui vous donne accès à ce module. Sinon, il existe un complément qui fait la même chose :

    https://download.cnet.com/Microsoft-Excel-Excess-Formatting-Cleaner-Add-in/3000-18483_4-10751861.html

    Au plaisir,

    Sophie

    #82908
    divjal
    Participant

    Bonjour ,

    Merci pour votre réponse rapide.

    En ce qui concerne mon avancement :
    Le fichier d’origine (fonctionnel , mais en phase “d’enjolivures”) est bien doté de macros.
    Par contre , je l’ai mis de coté ; puis crée un nouveau fichier (vierge de macros celui-là) , qui correspond bien aux défauts décrits par moi-même, plus haut.
    Pour être plus clair, On est bien en présence d’un problème identique sur mon fichier “fonctionnel” et sur mon fichier d'”essais”.
    (Je vous joins mon fichier d’essais. (Merci..))
    Aussi , étant sous XL 2013 , j’ai tenté l’essai d’ouvrir avec Excel 2016 : Mêmes Pbs.

    Je viens d’essayer avec Inquire : Blocage : pas d’amélioration
    L’option “XSFormatCleaner.xla” bloque la macro : “Set cmb = Application.CommandBars(“Chart Menu Bar”).Controls(“File”).CommandBar”

    NOUVEAU : En dernier lieu , pour être bien sur avant de vous envoyer le fichier : je viens de vérifier si, comme je le prétendais, celui-ci était bien libéré de ses macros … C’était sans compter celles étant dans le ThisWorkBool !!
    J’ai donc effacé ce qu’il y avait, refait l’essai pour vérifier que le Pb était toujours : Eh bien non, disparu !
    Fort de cela, j’ai donc essayé de remettre ce que j’avais effacé , pour “re-tester” : Pb toujours disparu!
    J’en perd un peu mon ‘latin’ (visual..) et je envoie donc mon fichier d’origine , vidé des éléments confidentiels et zippé. (MP : 1810)

    A vous lire.
    Bien cordialement.

    Attachments:
    You must be logged in to view attached files.
3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.