Changer la valeur d’une cellule depuis la saisie dans deux feuilles différentes

Accueil – Le CFO masqué Forums Excel Changer la valeur d’une cellule depuis la saisie dans deux feuilles différentes

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Articles
  • #57977
    Fx60
    Participant

    Bonjour @Tous,

    Dans l’exemple joint, je cherche à afficher la valeur de “G1” de l’onglet Base Facturation, que j’aurais saisi, dans la cellule “B4”.
    Mais aussi la possibilité de faire la même chose en saisissant une valeur dans “I1” de la feuille Devis PDF et la récupérer dans la cellule “B4” de l’onglet Base Facturation.
    Merci d’avance pour votre aide
    Cordialement.

    Attachments:
    You must be logged in to view attached files.
    #57997
    Kim Leblanc
    Participant

    Bonjour,

    Si je comprends bien, la valeur de B4 (onglet Base facturation) proviendrait de soit G1 de l’onglet Base facturation ou de I1 de l’onglet Denis PDF.

    Vous pourriez utiliser une case à cocher avec une formule qui réfère à la valeur de la case à cocher.

    Voir mon exemple dans votre fichier joint:
    La case à cocher Devis PDF est lié avec la cellule B1.
    si vous cocher la case Devis PDF alors la valeur affiché dans B1 sera vrai, sinon, faux.
    Il faut alors mettre une formule dans B4: =SI(B1=VRAI;’Devis PDF’!I1;’Base Facturation’!G1)
    Cela vous permettrait d’aller chercher la valeur de B4 à partir de l’un ou l’autre des deux endroits de saisie en cochant ou non la case à cocher.

    Au plaisir,

    Kim

    Attachments:
    You must be logged in to view attached files.
    #58078
    Fx60
    Participant

    Bonjour,

    Merci Kim pour votre réponse.
    Néanmoins, ce je que cherche à obtenir c’est plutôt la possibilité de saisir ma valeur que ce soit en G1 ou I1 à partir de la feuille active et qu’elle apparaisse en B4.
    Mais je pense qu’in fine, je serais obligé de passer par une macro VBA.
    N’est-ce pas?
    Merci tout de même.

    #58123
    Kim Leblanc
    Participant

    Bonjour,

    Si vous voulez que la valeur saisie dans G1 ou I1 apparaisse automatiquement dans B4 et que G1 et I1 peuvent avoir des valeurs différentes alors oui je crois que la solution serait de passer pas une macro VBA.

    Il y aurait également la possibilité d’utiliser une zone de texte (contrôle activeX) au lieu de G1 et une autre au lieu de I1 avec cellule lié sur B4 pour les 2 zones de texte. Mais à ce moment-là les 2 zones de textes seraient modifiées simultanément avec la valeur de saisie. Voir un exemple dans le fichier attaché.

    Bonne journée!

    Kim

    Attachments:
    You must be logged in to view attached files.
4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.